{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2024-10729","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","state":"PUBLISHED","assignerShortName":"Wordfence","dateReserved":"2024-11-02T06:41:45.827Z","datePublished":"2024-11-26T02:06:33.565Z","dateUpdated":"2026-04-08T16:59:47.974Z"},"containers":{"cna":{"providerMetadata":{"orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","shortName":"Wordfence","dateUpdated":"2026-04-08T16:59:47.974Z"},"affected":[{"vendor":"Tyche Softwares","product":"Booking & Appointment Plugin for WooCommerce","versions":[{"version":"0","status":"affected","lessThanOrEqual":"6.9.0","versionType":"semver"}],"defaultStatus":"unaffected"}],"descriptions":[{"lang":"en","value":"The Booking & Appointment Plugin for WooCommerce plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'save_google_calendar_data' function in versions up to, and including, 6.9.0. This makes it possible for authenticated attackers, with subscriber-level permissions or above to update the site options arbitrarily."}],"title":"Booking & Appointment Plugin for WooCommerce <= 6.9.0 - Authenticated (Subscriber+) Arbitrary Option Update","references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/6ed215da-10c5-469b-bab2-923808feebd4?source=cve"},{"url":"https://www.tychesoftwares.com/docs/docs/booking-appointment-plugin-for-woocommerce-new/changelog/"}],"problemTypes":[{"descriptions":[{"lang":"en","description":"CWE-285 Improper Authorization","cweId":"CWE-285","type":"CWE"}]}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","baseScore":8.8,"baseSeverity":"HIGH"}}],"credits":[{"lang":"en","type":"finder","value":"István Márton"}],"timeline":[{"time":"2024-11-02T00:00:00.000Z","lang":"en","value":"Discovered"},{"time":"2024-11-02T00:00:00.000Z","lang":"en","value":"Vendor Notified"},{"time":"2024-11-25T00:00:00.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"affected":[{"vendor":"tychesoftwares","product":"booking_and_appointment_plugin_for_woo_commerce","cpes":["cpe:2.3:a:tychesoftwares:booking_and_appointment_plugin_for_woo_commerce:*:*:*:*:*:*:*:*"],"defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"6.9.0","versionType":"semver"}]}],"metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2024-11-26T15:10:28.671855Z","id":"CVE-2024-10729","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"title":"CISA ADP Vulnrichment","providerMetadata":{"orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","shortName":"CISA-ADP","dateUpdated":"2024-11-26T15:11:56.622Z"}}]}}