{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2024-11445","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","state":"PUBLISHED","assignerShortName":"Wordfence","dateReserved":"2024-11-19T16:47:23.363Z","datePublished":"2025-01-07T04:21:59.744Z","dateUpdated":"2026-04-08T16:53:29.786Z"},"containers":{"cna":{"providerMetadata":{"orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","shortName":"Wordfence","dateUpdated":"2026-04-08T16:53:29.786Z"},"affected":[{"vendor":"sazzadh","product":"Image Magnify","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.1","versionType":"semver"}],"defaultStatus":"unaffected"}],"descriptions":[{"lang":"en","value":"The Image Magnify plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'image_magnify' shortcode in all versions up to, and including, 1.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page."}],"title":"Image Magnify <= 1.1 - Authenticated (Contributor+) Stored Cross-Site Scripting","references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/55838de5-0795-429b-be87-a0d57b29e471?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/image-magnify/trunk/image-magnify.php"},{"url":"https://wordpress.org/plugins/image-magnify/"}],"problemTypes":[{"descriptions":[{"lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","cweId":"CWE-79","type":"CWE"}]}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","baseScore":6.4,"baseSeverity":"MEDIUM"}}],"credits":[{"lang":"en","type":"finder","value":"zakaria"}],"timeline":[{"time":"2025-01-06T16:17:28.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-01-07T15:54:16.821732Z","id":"CVE-2024-11445","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"title":"CISA ADP Vulnrichment","providerMetadata":{"orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","shortName":"CISA-ADP","dateUpdated":"2025-01-07T16:23:47.156Z"}}]}}