{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2024-12634","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","state":"PUBLISHED","assignerShortName":"Wordfence","dateReserved":"2024-12-13T21:32:42.319Z","datePublished":"2025-03-07T11:12:54.726Z","dateUpdated":"2025-03-07T14:35:57.162Z"},"containers":{"cna":{"providerMetadata":{"orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","shortName":"Wordfence","dateUpdated":"2025-03-07T11:12:54.726Z"},"affected":[{"vendor":"pickplugins","product":"Related Posts, Inline Related Posts, Contextual Related Posts, Related Content By PickPlugins","versions":[{"version":"2.0.59","status":"affected"}],"defaultStatus":"unaffected"}],"descriptions":[{"lang":"en","value":"The Related Posts, Inline Related Posts, Contextual Related Posts, Related Content By PickPlugins plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including 2.0.59. This is due to missing nonce validation on a function. This makes it possible for unauthenticated attackers to inject malicious web scripts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link."}],"title":"Related Posts, Inline Related Posts, Contextual Related Posts, Related Content By PickPlugins <= 2.0.59 - Cross-Site Request Forgery to Stored Cross-Site Scripting","references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/29d22612-8e0d-4275-b370-9729352c951e?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/related-post/tags/2.0.58b/includes/menu/settings.php#L129"},{"url":"https://wordpress.org/plugins/related-post/#developers"},{"url":"https://plugins.trac.wordpress.org/changeset/3251482/"}],"problemTypes":[{"descriptions":[{"lang":"en","description":"CWE-352 Cross-Site Request Forgery (CSRF)","cweId":"CWE-352","type":"CWE"}]}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","baseScore":6.1,"baseSeverity":"MEDIUM"}}],"credits":[{"lang":"en","type":"finder","value":"Dale Mavers"}],"timeline":[{"time":"2025-03-06T21:30:44.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-03-07T14:34:47.196215Z","id":"CVE-2024-12634","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"title":"CISA ADP Vulnrichment","providerMetadata":{"orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","shortName":"CISA-ADP","dateUpdated":"2025-03-07T14:35:57.162Z"}}]}}