{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2024-13857","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","state":"PUBLISHED","assignerShortName":"Wordfence","dateReserved":"2025-02-10T22:55:29.229Z","datePublished":"2025-03-07T09:21:14.921Z","dateUpdated":"2026-04-08T17:23:59.917Z"},"containers":{"cna":{"providerMetadata":{"orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","shortName":"Wordfence","dateUpdated":"2026-04-08T17:23:59.917Z"},"affected":[{"vendor":"davidanderson","product":"WPGet API – Connect to any external REST API","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.2.10","versionType":"semver"}],"defaultStatus":"unaffected"}],"descriptions":[{"lang":"en","value":"The WPGet API – Connect to any external REST API plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 2.2.10. This makes it possible for authenticated attackers, with Administrator-level access and above, to make web requests to arbitrary locations originating from the web application which can be used to query and modify information from internal services."}],"title":"WPGet API <= 2.2.10 - Authenticated (Administrator+) Server-Side Request Forgery","references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/cd2a8e7b-6fca-49f3-ba6d-bdaa418f611a?source=cve"},{"url":"https://wordpress.org/plugins/wpgetapi/#developers"},{"url":"https://plugins.trac.wordpress.org/changeset/3251647/"}],"problemTypes":[{"descriptions":[{"lang":"en","description":"CWE-918 Server-Side Request Forgery (SSRF)","cweId":"CWE-918","type":"CWE"}]}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N","baseScore":5.5,"baseSeverity":"MEDIUM"}}],"credits":[{"lang":"en","type":"finder","value":"Francesco Carlucci"}],"timeline":[{"time":"2025-03-06T20:56:52.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-03-07T13:35:50.583158Z","id":"CVE-2024-13857","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"title":"CISA ADP Vulnrichment","providerMetadata":{"orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","shortName":"CISA-ADP","dateUpdated":"2025-03-07T13:36:06.585Z"}}]}}