{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-12016","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","state":"PUBLISHED","assignerShortName":"Wordfence","dateReserved":"2025-10-21T13:52:07.646Z","datePublished":"2025-10-24T08:23:55.993Z","dateUpdated":"2026-04-08T16:33:53.622Z"},"containers":{"cna":{"providerMetadata":{"orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","shortName":"Wordfence","dateUpdated":"2026-04-08T16:33:53.622Z"},"affected":[{"vendor":"muniyandibg","product":"qnotsquiz","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.0.0","versionType":"semver"}],"defaultStatus":"unaffected"}],"descriptions":[{"lang":"en","value":"The qnotsquiz plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'qnotsquiz_custom_start_text' parameter in all versions up to, and including, 1.0.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level access, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled."}],"title":"qnotsquiz <= 1.0.0 - Authenticated (Admin+) Stored Cross-Site Scripting","references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/07043be9-c81e-4021-90af-976ae57c0bec?source=cve"},{"url":"https://wordpress.org/plugins/qnotsquiz/"}],"problemTypes":[{"descriptions":[{"lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","cweId":"CWE-79","type":"CWE"}]}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N","baseScore":4.4,"baseSeverity":"MEDIUM"}}],"credits":[{"lang":"en","type":"finder","value":"dayea song"}],"timeline":[{"time":"2025-10-23T19:55:50.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-10-24T16:47:28.956798Z","id":"CVE-2025-12016","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"title":"CISA ADP Vulnrichment","providerMetadata":{"orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","shortName":"CISA-ADP","dateUpdated":"2025-10-24T16:48:00.636Z"}}]}}