{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-14166","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","state":"PUBLISHED","assignerShortName":"Wordfence","dateReserved":"2025-12-05T21:21:47.576Z","datePublished":"2025-12-12T03:20:46.466Z","dateUpdated":"2026-04-08T16:56:35.965Z"},"containers":{"cna":{"providerMetadata":{"orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","shortName":"Wordfence","dateUpdated":"2026-04-08T16:56:35.965Z"},"affected":[{"vendor":"ludwigyou","product":"WPMasterToolKit (WPMTK) – All in one plugin","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.13.0","versionType":"semver"}],"defaultStatus":"unaffected"}],"descriptions":[{"lang":"en","value":"The WPMasterToolKit plugin for WordPress is vulnerable to PHP Code Injection in all versions up to, and including, 2.13.0. This is due to the plugin allowing Author-level users to create and execute arbitrary PHP code through the Code Snippets feature without proper capability checks. This makes it possible for authenticated attackers, with Contributor-level access and above, to execute arbitrary PHP code on the server, leading to remote code execution, privilege escalation, and complete site compromise."}],"title":"WPMasterToolKit (WPMTK) <= 2.13.0 - Authenticated (Contributor+) Code Injection","references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/6049996a-514a-44f7-9878-4aa43598842a?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/wpmastertoolkit/trunk/admin/modules/core/class-code-snippets.php#L135"},{"url":"https://plugins.trac.wordpress.org/browser/wpmastertoolkit/tags/2.13.0/admin/modules/core/class-code-snippets.php#L135"},{"url":"https://plugins.trac.wordpress.org/browser/wpmastertoolkit/trunk/admin/modules/core/class-code-snippets.php#L628"},{"url":"https://plugins.trac.wordpress.org/browser/wpmastertoolkit/tags/2.13.0/admin/modules/core/class-code-snippets.php#L628"},{"url":"https://plugins.trac.wordpress.org/log/wpmastertoolkit/"}],"problemTypes":[{"descriptions":[{"lang":"en","description":"CWE-94 Improper Control of Generation of Code ('Code Injection')","cweId":"CWE-94","type":"CWE"}]}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N","baseScore":5.3,"baseSeverity":"MEDIUM"}}],"credits":[{"lang":"en","type":"finder","value":"Athiwat Tiprasaharn"},{"lang":"en","type":"finder","value":"Itthidej Aramsri"},{"lang":"en","type":"finder","value":"Powpy"},{"lang":"en","type":"finder","value":"Waris Damkham"},{"lang":"en","type":"finder","value":"Varakorn Chanthasri"},{"lang":"en","type":"finder","value":"Peerapat Samatathanyakorn"},{"lang":"en","type":"finder","value":"Sopon Tangpathum (SoNaJaa)"}],"timeline":[{"time":"2025-12-11T14:32:15.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-12-15T17:54:30.314072Z","id":"CVE-2025-14166","options":[{"Exploitation":"none"},{"Automatable":"yes"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"title":"CISA ADP Vulnrichment","providerMetadata":{"orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","shortName":"CISA-ADP","dateUpdated":"2025-12-15T18:15:27.698Z"}}]}}