{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-23712","assignerOrgId":"21595511-bba5-4825-b968-b78d1f9984a3","state":"PUBLISHED","assignerShortName":"Patchstack","dateReserved":"2025-01-16T11:28:39.044Z","datePublished":"2025-01-16T20:06:47.304Z","dateUpdated":"2026-04-28T16:11:17.723Z"},"containers":{"cna":{"affected":[{"collectionURL":"https://wordpress.org/plugins","defaultStatus":"unaffected","packageName":"kapost-byline","product":"Kapost","vendor":"kapostintegrations","versions":[{"changes":[{"at":"2.3.0","status":"unaffected"}],"lessThanOrEqual":"2.2.9","status":"affected","version":"0","versionType":"custom"}]}],"credits":[{"lang":"en","type":"finder","value":"SOPROBRO | Patchstack Bug Bounty Program"}],"datePublic":"2026-04-01T16:33:13.830Z","descriptions":[{"lang":"en","supportingMedia":[{"base64":false,"type":"text/html","value":"Cross-Site Request Forgery (CSRF) vulnerability in kapostintegrations Kapost kapost-byline allows Stored XSS.<p>This issue affects Kapost: from n/a through <= 2.2.9.</p>"}],"value":"Cross-Site Request Forgery (CSRF) vulnerability in kapostintegrations Kapost kapost-byline allows Stored XSS.This issue affects Kapost: from n/a through <= 2.2.9."}],"impacts":[{"capecId":"CAPEC-592","descriptions":[{"lang":"en","value":"Stored XSS"}]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"LOW","baseScore":7.1,"baseSeverity":"HIGH","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"NONE","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L","version":"3.1"},"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-352","description":"Cross-Site Request Forgery (CSRF)","lang":"en","type":"CWE"}]}],"providerMetadata":{"orgId":"21595511-bba5-4825-b968-b78d1f9984a3","shortName":"Patchstack","dateUpdated":"2026-04-28T16:11:17.723Z"},"references":[{"tags":["vdb-entry"],"url":"https://patchstack.com/database/Wordpress/Plugin/kapost-byline/vulnerability/wordpress-kapost-plugin-2-2-9-csrf-to-stored-xss-vulnerability?_s_id=cve"}],"title":"WordPress Kapost plugin <= 2.2.9 - CSRF to Stored XSS vulnerability"},"adp":[{"metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-01-17T17:19:17.361962Z","id":"CVE-2025-23712","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"title":"CISA ADP Vulnrichment","providerMetadata":{"orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","shortName":"CISA-ADP","dateUpdated":"2025-01-17T19:12:24.679Z"}}]}}