{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-30618","assignerOrgId":"21595511-bba5-4825-b968-b78d1f9984a3","state":"PUBLISHED","assignerShortName":"Patchstack","dateReserved":"2025-03-24T13:00:47.778Z","datePublished":"2025-06-17T15:01:38.032Z","dateUpdated":"2026-04-28T16:11:55.871Z"},"containers":{"cna":{"affected":[{"collectionURL":"https://wordpress.org/plugins","defaultStatus":"unaffected","packageName":"rapyd-payments","product":"Rapyd Payment Extension for WooCommerce","vendor":"yuliaz","versions":[{"changes":[{"at":"1.2.1","status":"unaffected"}],"lessThanOrEqual":"1.2.0","status":"affected","version":"0","versionType":"custom"}]}],"credits":[{"lang":"en","type":"finder","value":"Martino Spagnuolo (r3verii) | Patchstack Bug Bounty Program"}],"datePublic":"2026-04-01T16:36:25.422Z","descriptions":[{"lang":"en","supportingMedia":[{"base64":false,"type":"text/html","value":"Deserialization of Untrusted Data vulnerability in yuliaz Rapyd Payment Extension for WooCommerce rapyd-payments allows Object Injection.<p>This issue affects Rapyd Payment Extension for WooCommerce: from n/a through <= 1.2.0.</p>"}],"value":"Deserialization of Untrusted Data vulnerability in yuliaz Rapyd Payment Extension for WooCommerce rapyd-payments allows Object Injection.This issue affects Rapyd Payment Extension for WooCommerce: from n/a through <= 1.2.0."}],"impacts":[{"capecId":"CAPEC-586","descriptions":[{"lang":"en","value":"Object Injection"}]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"HIGH","baseScore":9.8,"baseSeverity":"CRITICAL","confidentialityImpact":"HIGH","integrityImpact":"HIGH","privilegesRequired":"NONE","scope":"UNCHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-502","description":"Deserialization of Untrusted Data","lang":"en","type":"CWE"}]}],"providerMetadata":{"orgId":"21595511-bba5-4825-b968-b78d1f9984a3","shortName":"Patchstack","dateUpdated":"2026-04-28T16:11:55.871Z"},"references":[{"tags":["vdb-entry"],"url":"https://patchstack.com/database/Wordpress/Plugin/rapyd-payments/vulnerability/wordpress-rapyd-payment-extension-for-woocommerce-1-1-9-php-object-injection-vulnerability?_s_id=cve"}],"title":"WordPress Rapyd Payment Extension for WooCommerce plugin <= 1.2.0 - PHP Object Injection Vulnerability"},"adp":[{"metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-06-17T18:34:45.571721Z","id":"CVE-2025-30618","options":[{"Exploitation":"none"},{"Automatable":"yes"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"title":"CISA ADP Vulnrichment","providerMetadata":{"orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","shortName":"CISA-ADP","dateUpdated":"2025-06-17T18:36:27.738Z"}}]}}