{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-3776","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","state":"PUBLISHED","assignerShortName":"Wordfence","dateReserved":"2025-04-17T17:19:49.099Z","datePublished":"2025-04-24T08:23:52.626Z","dateUpdated":"2026-04-08T17:31:31.207Z"},"containers":{"cna":{"providerMetadata":{"orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","shortName":"Wordfence","dateUpdated":"2026-04-08T17:31:31.207Z"},"affected":[{"vendor":"cajka","product":"Verification SMS with TargetSMS","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.5","versionType":"semver"}],"defaultStatus":"unaffected"}],"descriptions":[{"lang":"en","value":"The Verification SMS with TargetSMS plugin for WordPress is vulnerable to limited Remote Code Execution in all versions up to, and including, 1.5 via the 'targetvr_ajax_handler' function. This is due to a lack of validation on the type of function that can be called. This makes it possible for unauthenticated attackers to execute any callable function on the site, such as phpinfo()."}],"title":"Verification SMS with TargetSMS <= 1.5 - Unauthenticated Limited Remote Code Execution","references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/ed08d248-7467-4a3b-91a2-4286d91b9c50?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/verification-sms-targetsms/trunk/inc/ajax.php#L7"},{"url":"https://plugins.trac.wordpress.org/browser/verification-sms-targetsms/trunk/inc/ajax.php#L9"}],"problemTypes":[{"descriptions":[{"lang":"en","description":"CWE-94 Improper Control of Generation of Code ('Code Injection')","cweId":"CWE-94","type":"CWE"}]}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L","baseScore":8.3,"baseSeverity":"HIGH"}}],"credits":[{"lang":"en","type":"finder","value":"Cheng Liu"}],"timeline":[{"time":"2025-04-23T19:47:36.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-04-24T12:52:53.808595Z","id":"CVE-2025-3776","options":[{"Exploitation":"none"},{"Automatable":"yes"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"title":"CISA ADP Vulnrichment","providerMetadata":{"orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","shortName":"CISA-ADP","dateUpdated":"2025-04-24T13:06:21.124Z"}}]}}