{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2025-40914","assignerOrgId":"9b29abf9-4ab0-4765-b253-1875cd9b441e","state":"PUBLISHED","assignerShortName":"CPANSec","dateReserved":"2025-04-16T09:05:34.361Z","datePublished":"2025-06-11T14:06:53.418Z","dateUpdated":"2025-06-11T14:43:31.248Z"},"containers":{"cna":{"affected":[{"collectionURL":"https://cpan.org/modules","defaultStatus":"unaffected","packageName":"CryptX","product":"CryptX","programFiles":["src/ltm/bn_mp_grow.c"],"repo":"https://github.com/DCIT/perl-CryptX","vendor":"MIK","versions":[{"lessThanOrEqual":"0.086","status":"affected","version":"0.002","versionType":"custom"}]}],"descriptions":[{"lang":"en","supportingMedia":[{"base64":false,"type":"text/html","value":"<div>Perl CryptX before version 0.087 contains a dependency that may be susceptible to an integer overflow.</div><div>CryptX embeds a version of the libtommath library that is susceptible to an integer overflow associated with CVE-2023-36328.</div>"}],"value":"Perl CryptX before version 0.087 contains a dependency that may be susceptible to an integer overflow.\n\nCryptX embeds a version of the libtommath library that is susceptible to an integer overflow associated with CVE-2023-36328."}],"problemTypes":[{"descriptions":[{"cweId":"CWE-1395","description":"CWE-1395 Dependency on Vulnerable Third-Party Component","lang":"en","type":"CWE"}]}],"providerMetadata":{"orgId":"9b29abf9-4ab0-4765-b253-1875cd9b441e","shortName":"CPANSec","dateUpdated":"2025-06-11T14:06:53.418Z"},"references":[{"url":"https://www.cve.org/CVERecord?id=CVE-2023-36328"},{"url":"https://github.com/libtom/libtommath/pull/546"},{"url":"https://github.com/advisories/GHSA-j3xv-6967-cv88"},{"url":"https://metacpan.org/release/MIK/CryptX-0.086/source/src/ltm/bn_mp_grow.c"}],"solutions":[{"lang":"en","supportingMedia":[{"base64":false,"type":"text/html","value":"Users should update to version 0.087 or later"}],"value":"Users should update to version 0.087 or later"}],"source":{"discovery":"UNKNOWN"},"title":"Perl CryptX before version 0.087 contains a dependency that may be susceptible to an integer overflow","x_generator":{"engine":"Vulnogram 0.2.0"}},"adp":[{"metrics":[{"cvssV3_1":{"scope":"UNCHANGED","version":"3.1","baseScore":9.8,"attackVector":"NETWORK","baseSeverity":"CRITICAL","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","integrityImpact":"HIGH","userInteraction":"NONE","attackComplexity":"LOW","availabilityImpact":"HIGH","privilegesRequired":"NONE","confidentialityImpact":"HIGH"}},{"other":{"type":"ssvc","content":{"timestamp":"2025-06-11T14:33:49.813767Z","id":"CVE-2025-40914","options":[{"Exploitation":"none"},{"Automatable":"yes"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"title":"CISA ADP Vulnrichment","providerMetadata":{"orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","shortName":"CISA-ADP","dateUpdated":"2025-06-11T14:43:31.248Z"}}]}}