{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2025-58450","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","state":"PUBLISHED","assignerShortName":"GitHub_M","dateReserved":"2025-09-01T20:03:06.533Z","datePublished":"2025-09-08T21:35:01.452Z","dateUpdated":"2025-09-09T13:30:44.306Z"},"containers":{"cna":{"title":"pREST has Systemic SQL Injection Vulnerability","problemTypes":[{"descriptions":[{"cweId":"CWE-89","lang":"en","description":"CWE-89: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')","type":"CWE"}]}],"metrics":[{"cvssV4_0":{"attackVector":"NETWORK","attackComplexity":"LOW","attackRequirements":"NONE","privilegesRequired":"NONE","userInteraction":"NONE","vulnConfidentialityImpact":"HIGH","vulnIntegrityImpact":"HIGH","vulnAvailabilityImpact":"HIGH","subConfidentialityImpact":"NONE","subIntegrityImpact":"NONE","subAvailabilityImpact":"NONE","baseScore":9.3,"baseSeverity":"CRITICAL","vectorString":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"}}],"references":[{"name":"https://github.com/prest/prest/security/advisories/GHSA-p46v-f2x8-qp98","tags":["x_refsource_CONFIRM"],"url":"https://github.com/prest/prest/security/advisories/GHSA-p46v-f2x8-qp98"},{"name":"https://github.com/prest/prest/commit/47d02b87842900f77d76fc694d9aa7e983b0711c","tags":["x_refsource_MISC"],"url":"https://github.com/prest/prest/commit/47d02b87842900f77d76fc694d9aa7e983b0711c"}],"affected":[{"vendor":"prest","product":"prest","versions":[{"version":"< 2.0.0-rc3","status":"affected"}]}],"providerMetadata":{"orgId":"a0819718-46f1-4df5-94e2-005712e83aaa","shortName":"GitHub_M","dateUpdated":"2025-09-08T21:35:01.452Z"},"descriptions":[{"lang":"en","value":"pREST (PostgreSQL REST), is an API that delivers an application on top of a Postgres database. SQL injection is possible in versions prior to 2.0.0-rc3. The validation present in versions prior to 2.0.0-rc3 does not provide adequate protection from injection attempts. Version 2.0.0-rc3 contains a patch to mitigate such attempts."}],"source":{"advisory":"GHSA-p46v-f2x8-qp98","discovery":"UNKNOWN"}},"adp":[{"references":[{"url":"https://github.com/prest/prest/security/advisories/GHSA-p46v-f2x8-qp98","tags":["exploit"]}],"metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-09-09T13:16:04.505475Z","id":"CVE-2025-58450","options":[{"Exploitation":"poc"},{"Automatable":"yes"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"title":"CISA ADP Vulnrichment","providerMetadata":{"orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","shortName":"CISA-ADP","dateUpdated":"2025-09-09T13:30:44.306Z"}}]}}