{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-8481","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","state":"PUBLISHED","assignerShortName":"Wordfence","dateReserved":"2025-08-01T17:41:03.395Z","datePublished":"2025-09-11T07:24:57.926Z","dateUpdated":"2026-04-08T17:17:53.178Z"},"containers":{"cna":{"providerMetadata":{"orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","shortName":"Wordfence","dateUpdated":"2026-04-08T17:17:53.178Z"},"affected":[{"vendor":"mdimran41","product":"Blog Designer For Elementor – Post Slider, Post Carousel, Post Grid","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.1.7","versionType":"semver"}],"defaultStatus":"unaffected"}],"descriptions":[{"lang":"en","value":"The Blog Designer For Elementor – Post Slider, Post Carousel, Post Grid plugin for WordPress is vulnerable to Cross-Site Request Forgery in version 1.1.7. This is due to missing or incorrect nonce validation on the bdfe_install_activate_rswpbs_only function. This makes it possible for unauthenticated attackers to install the 'rs-wp-books-showcase' plugin via a forged request granted they can trick a site administrator into performing an action such as clicking on a link."}],"title":"Blog Designer For Elementor – Post Slider, Post Carousel, Post Grid <= 1.1.7 - Cross-Site Request Forgery","references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/b8f31f8e-03a0-436c-bfa3-bc41d70e8e2a?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/blog-designer-for-elementor/tags/1.1.7/inc/import-books-from-amazon-notice/import-books-from-amazon-notice.php#L109"}],"problemTypes":[{"descriptions":[{"lang":"en","description":"CWE-352 Cross-Site Request Forgery (CSRF)","cweId":"CWE-352","type":"CWE"}]}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","baseScore":4.3,"baseSeverity":"MEDIUM"}}],"credits":[{"lang":"en","type":"finder","value":"wesley"}],"timeline":[{"time":"2025-09-10T18:55:20.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-09-11T13:44:47.733139Z","id":"CVE-2025-8481","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"title":"CISA ADP Vulnrichment","providerMetadata":{"orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","shortName":"CISA-ADP","dateUpdated":"2025-09-11T14:38:26.145Z"}}]}}