{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-8905","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","state":"PUBLISHED","assignerShortName":"Wordfence","dateReserved":"2025-08-12T19:54:09.748Z","datePublished":"2025-08-15T08:25:41.084Z","dateUpdated":"2026-04-08T17:24:03.908Z"},"containers":{"cna":{"providerMetadata":{"orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","shortName":"Wordfence","dateUpdated":"2026-04-08T17:24:03.908Z"},"affected":[{"vendor":"inpersttion","product":"Inpersttion For Theme","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.0","versionType":"semver"}],"defaultStatus":"unaffected"}],"descriptions":[{"lang":"en","value":"The Inpersttion For Theme plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 1.0 via the theme_section_shortcode() function. This is due to the plugin not restricting what functions can be called. This makes it possible for authenticated attackers, with Contributor-level access and above, to execute code on the server which is limited to arbitrary functions without any user supplied parameters."}],"title":"Inpersttion For Theme <= 1.0 - Authenticated (Contributor+) Arbitrary Function Call","references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/cd4dc8ab-792b-41ff-a7b9-77a11c02d91b?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/err-our-team/trunk/inc/inpersttion-for-shortcode.php#L8"}],"problemTypes":[{"descriptions":[{"lang":"en","description":"CWE-94 Improper Control of Generation of Code ('Code Injection')","cweId":"CWE-94","type":"CWE"}]}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","baseScore":6.3,"baseSeverity":"MEDIUM"}}],"credits":[{"lang":"en","type":"finder","value":"Peter Thaleikis"}],"timeline":[{"time":"2025-08-14T20:16:19.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-08-15T16:07:39.480004Z","id":"CVE-2025-8905","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"title":"CISA ADP Vulnrichment","providerMetadata":{"orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","shortName":"CISA-ADP","dateUpdated":"2025-08-15T16:07:46.703Z"}}]}}