CVE-2026-100300
Apache ZooKeeper: Unauthenticated persistent denial of service via unvalidated quota-node data and paths crashing the transaction-apply thread
Description
Improper handling of exceptional conditions in the quota subsystem of Apache ZooKeeper allows an attacker able to write under the /zookeeper/quota subtree — unauthenticated on default deployments, where that subtree is world-writable — to crash the server's critical request-processing thread and render the on-disk data directory permanently unbootable. This issue affects Apache ZooKeeper up to and including 3.9.6. Users are recommended to upgrade to version 3.8.8 or 3.9.7, which fixes the issue.
Affected products
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache ZooKeeper | 3.9.0 to ≤3.9.6; 3.8.0 to ≤3.8.7 |
References
External links from the record. They lead to third-party sites.