{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-42457","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","state":"PUBLISHED","assignerShortName":"GitHub_M","dateReserved":"2026-04-27T13:55:58.693Z","datePublished":"2026-05-14T14:48:05.096Z","dateUpdated":"2026-05-14T19:51:50.476Z"},"containers":{"cna":{"title":"vCluster Platform: Stored XSS can lead to privilege escalation","problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"HIGH","baseScore":9,"baseSeverity":"CRITICAL","confidentialityImpact":"HIGH","integrityImpact":"HIGH","privilegesRequired":"LOW","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H","version":"3.1"}}],"references":[{"name":"https://github.com/loft-sh/loft/security/advisories/GHSA-x7cq-v3h6-426c","tags":["x_refsource_CONFIRM"],"url":"https://github.com/loft-sh/loft/security/advisories/GHSA-x7cq-v3h6-426c"}],"affected":[{"vendor":"loft-sh","product":"loft","versions":[{"version":"< 4.4.3","status":"affected"},{"version":">=4.5.0-alpha.0 , < 4.5.5","status":"affected"},{"version":">= 4.6.0-alpha.1, < 4.6.2","status":"affected"},{"version":">= 4.7.0-alpha.0, < 4.7.1","status":"affected"}]}],"providerMetadata":{"orgId":"a0819718-46f1-4df5-94e2-005712e83aaa","shortName":"GitHub_M","dateUpdated":"2026-05-14T14:48:05.096Z"},"descriptions":[{"lang":"en","value":"vCluster Platform provides a Kubernetes platform for managing virtual clusters, multi-tenancy, and cluster sharing. Prior to 4.4.3, 4.5.5, 4.6.2, 4.7.1, and 4.8.0, there is a Stored XSS attack vulnerability via the name field of a templateRef. This can lead to the execution of arbitrary external scripts within the platform's browser context. In the worst case, a malicious user could potentially create a new Global-Admin user, bypassing other security restrictions. The attacker needs the ability to create namespaces. This vulnerability is fixed in 4.4.3, 4.5.5, 4.6.2, 4.7.1, and 4.8.0."}],"source":{"advisory":"GHSA-x7cq-v3h6-426c","discovery":"UNKNOWN"}},"adp":[{"metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-05-14T16:02:15.926679Z","id":"CVE-2026-42457","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"title":"CISA ADP Vulnrichment","providerMetadata":{"orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","shortName":"CISA-ADP","dateUpdated":"2026-05-14T19:51:50.476Z"}}]}}