GHSA-3h4r-pjv6-cph9
RubyGems Escape sequence injection vulnerability in api response handling
Packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| RubyGems | rubygems-update | >= 2.6.0, < 2.7.9 | 2.7.9 |
| RubyGems | rubygems-update | >= 3.0.0, < 3.0.2 | 3.0.2 |
Details
As written in the advisory (Markdown source, shown as plain text).
An issue was discovered in RubyGems 2.6 and later through 3.0.2. Gem::GemcutterUtilities#with_response may output the API response to stdout as it is. Therefore, if the API side modifies the response, escape sequence injection may occur.
References
External links from the advisory. They lead to third-party sites.
- https://nvd.nist.gov/vuln/detail/CVE-2019-8323
- https://hackerone.com/reports/315081
- https://blog.rubygems.org/2019/03/05/security-advisories-2019-03.html
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rubygems-update/CVE-2019-8323.yml
- https://lists.debian.org/debian-lts-announce/2020/08/msg00027.html
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00036.html