~ / search / GHSA-47r2-phr8-m8cp

GHSA-47r2-phr8-m8cp

Apache Pulsar Broker Improper Authentication vulnerability

Source: GitHub Advisory Database (reviewed) Moderate CVE-2023-31007

Packages

EcosystemPackageAffectedFixed in
Maven org.apache.pulsar:pulsar-broker >= 2.9.0, < 2.10.4 2.10.4
Maven org.apache.pulsar:pulsar-broker >= 2.11.0, < 2.11.1 2.11.1

Details

As written in the advisory (Markdown source, shown as plain text).

Improper Authentication vulnerability in Apache Software Foundation Apache Pulsar Broker allows a client to stay connected to a broker after authentication data expires if the client connected through the Pulsar Proxy when the broker is configured with authenticateOriginalAuthData=false or if a client connects directly to a broker with a specially crafted connect command when the broker is configured with authenticateOriginalAuthData=false. This issue affects Apache Pulsar: through 2.9.4, from 2.10.0 through 2.10.3, 2.11.0. 2.9 Pulsar Broker users should upgrade to at least 2.9.5. 2.10 Pulsar Broker users should upgrade to at least 2.10.4. 2.11 Pulsar Broker users should upgrade to at least 2.11.1. 3.0 Pulsar Broker users are unaffected. Any users running the Pulsar Broker for 2.8.* and earlier should upgrade to one of the above patched versions.

References

External links from the advisory. They lead to third-party sites.