~ / search / GHSA-47w3-66wq-cpxg

GHSA-47w3-66wq-cpxg

Improper Input Validation in Apache Kafka

Source: GitHub Advisory Database (reviewed) High CVE-2018-17196

Packages

EcosystemPackageAffectedFixed in
Maven org.apache.kafka:kafka >= 0.11.0.0, < 2.1.1 2.1.1

Details

As written in the advisory (Markdown source, shown as plain text).

In Apache Kafka versions between 0.11.0.0 and 2.1.0, it is possible to manually craft a Produce request which bypasses transaction/idempotent ACL validation. Only authenticated clients with Write permission on the respective topics are able to exploit this vulnerability. Users should upgrade to 2.1.1 or later where this vulnerability has been fixed.

References

External links from the advisory. They lead to third-party sites.