~ / search / GHSA-69fv-gw6g-8ccg

GHSA-69fv-gw6g-8ccg

Potential memory corruption in arrayfire

Source: GitHub Advisory Database (reviewed) Critical CVE-2018-20998

Packages

EcosystemPackageAffectedFixed in
crates.io arrayfire < 3.6.0 3.6.0
PyPI arrayfire < 3.6.0 3.6.0

Details

As written in the advisory (Markdown source, shown as plain text).

The attribute repr() added to enums to be compatible with C-FFI caused memory corruption on MSVC toolchain. arrayfire crates <= version 3.5.0 do not have this issue when used with Rust versions 1.27 or earlier. The issue only started to appear since Rust version 1.28. The issue seems to be interlinked with which version of Rust is being used. The issue was fixed in crate 3.6.0.

References

External links from the advisory. They lead to third-party sites.