GHSA-6vfg-8ppv-h5hg
MediaWiki Incorrect Access Control vulnerability
Packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| Packagist | mediawiki/core | < 1.27.6 | 1.27.6 |
| Packagist | mediawiki/core | >= 1.30.0, < 1.30.2 | 1.30.2 |
| Packagist | mediawiki/core | >= 1.31.0, < 1.31.2 | 1.31.2 |
| Packagist | mediawiki/core | >= 1.32.0, < 1.32.2 | 1.32.2 |
Details
As written in the advisory (Markdown source, shown as plain text).
MediaWiki through 1.32.1 has Incorrect Access Control (issue 1 of 3). A spammer can use Special:ChangeEmail to send out spam with no rate limiting or ability to block them. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.
References
External links from the advisory. They lead to third-party sites.
- https://nvd.nist.gov/vuln/detail/CVE-2019-12467
- https://github.com/FriendsOfPHP/security-advisories/blob/master/mediawiki/core/CVE-2019-12467.yaml
- https://github.com/wikimedia/mediawiki
- https://lists.wikimedia.org/pipermail/wikitech-l/2019-June/092152.html
- https://phabricator.wikimedia.org/T209794
- https://seclists.org/bugtraq/2019/Jun/12
- https://www.debian.org/security/2019/dsa-4460