GHSA-8rhc-48pp-52gr
Apache Spark Deserialization of Untrusted Data vulnerability
Packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| Maven | org.apache.spark:spark-core_2.11 | < 2.1.2 | 2.1.2 |
| Maven | org.apache.spark:spark-core_2.10 | < 2.1.2 | 2.1.2 |
| PyPI | pyspark | < 2.1.2 | 2.1.2 |
Details
As written in the advisory (Markdown source, shown as plain text).
In Apache Spark 1.6.0 until 2.1.1, the launcher API performs unsafe deserialization of data received by its socket. This makes applications launched programmatically using the launcher API potentially vulnerable to arbitrary code execution by an attacker with access to any user account on the local machine. It does not affect apps run by spark-submit or spark-shell. The attacker would be able to execute code as the user that ran the Spark application. Users are encouraged to update to version 2.1.2, 2.2.0 or later.
References
External links from the advisory. They lead to third-party sites.