~ / search / GHSA-9j7m-rjqx-48vh

GHSA-9j7m-rjqx-48vh

RubyGems Regular Expression Denial of Service vulnerability

Source: GitHub Advisory Database (reviewed) Moderate CVE-2013-4287

Packages

EcosystemPackageAffectedFixed in
RubyGems rubygems-update < 1.8.23.1 1.8.23.1
RubyGems rubygems-update >= 1.8.24, < 1.8.26 1.8.26
RubyGems rubygems-update >= 2.0.0, < 2.0.8 2.0.8
RubyGems rubygems-update >= 2.1.0.rc.1, < 2.1.0 2.1.0

Details

As written in the advisory (Markdown source, shown as plain text).

Algorithmic complexity vulnerability in Gem::Version::VERSION_PATTERN in `lib/rubygems/version.rb` in RubyGems before 1.8.23.1, 1.8.24 through 1.8.25, 2.0.x before 2.0.8, and 2.1.x before 2.1.0, as used in Ruby 1.9.0 through 2.0.0p247, allows remote attackers to cause a denial of service (CPU consumption) via a crafted gem version that triggers a large amount of backtracking in a regular expression.

References

External links from the advisory. They lead to third-party sites.