~ / search / GHSA-cqr7-78pj-3g7j

GHSA-cqr7-78pj-3g7j

File Descriptor Leak Can Cause DoS Vulnerability in hapi

Source: GitHub Advisory Database (reviewed) High CVE-2014-3742

Packages

EcosystemPackageAffectedFixed in
npm hapi >= 2.0.0, < 2.2.0 2.2.0

Details

As written in the advisory (Markdown source, shown as plain text).

Versions 2.0.x and 2.1.x of hapi are vulnerable to a denial of service attack via a file descriptor leak. When triggered repeatedly, this leak will cause the server to run out of file descriptors and the node process to die. The effort required to take down a server depends on the process file descriptor limit. No other side effects or exploits have been identified. ## Recommendation - Please upgrade to version 2.2.x or above as soon as possible.

References

External links from the advisory. They lead to third-party sites.