GHSA-g78h-pf65-46rv
Enhanced Image plugin for CKEditor is vulnerable to Cross-site scripting (XSS)
Packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| Packagist | drupal/core | >= 8.5.0, < 8.5.2 | 8.5.2 |
| npm | ckeditor-dev | >= 4.5.10, < 4.9.2 | 4.9.2 |
| Packagist | drupal/core | >= 8.0, < 8.4.7 | 8.4.7 |
| Packagist | drupal/drupal | >= 8.0, < 8.4.7 | 8.4.7 |
| Packagist | drupal/drupal | >= 8.5, < 8.5.2 | 8.5.2 |
Details
As written in the advisory (Markdown source, shown as plain text).
The Enhanced Image (aka [image2](https://github.com/ckeditor/ckeditor4/tree/master/plugins/image2)) plugin for CKEditor in versions 4.5.10 through 4.9.1; fixed in 4.9.2, and as used in Drupal 8 before 8.4.7 and 8.5.x before 8.5.2 and other products, is vulnerable to cross-site scripting because it allows remote attackers to inject arbitrary web script through a crafted IMG element.
References
External links from the advisory. They lead to third-party sites.
- https://nvd.nist.gov/vuln/detail/CVE-2018-9861
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/core/CVE-2018-9861.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/drupal/CVE-2018-9861.yaml
- https://github.com/ckeditor/ckeditor-dev/blob/master/CHANGES.md
- https://www.drupal.org/sa-core-2018-003
- https://www.oracle.com/technetwork/security-advisory/cpujul2019-5072835.html
- http://www.securityfocus.com/bid/103924