GHSA-g9hh-vvx3-v37v
Denial of service in HtmlUnit-Neko
Packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| Maven | net.sourceforge.htmlunit:neko-htmlunit | < 2.27 | 2.27 |
Details
As written in the advisory (Markdown source, shown as plain text).
Certain Neko-related HTML parsers allow a denial of service via crafted Processing Instruction (PI) input that causes excessive heap memory consumption. In particular, this issue exists in HtmlUnit-Neko through 2.26, and is fixed in 2.27. This issue also exists in CyberNeko HTML through 1.9.22 (also affecting OWASP AntiSamy before 1.6.6), but 1.9.22 is the last version of CyberNeko HTML. NOTE: this may be related to CVE-2022-24939.
References
External links from the advisory. They lead to third-party sites.