~ / search / GHSA-gx69-6cp4-hxrj

GHSA-gx69-6cp4-hxrj

RubyGems Link Following vulnerability

Source: GitHub Advisory Database (reviewed) High CVE-2018-1000073

Packages

EcosystemPackageAffectedFixed in
RubyGems rubygems-update < 2.7.6 2.7.6
Maven org.jruby:jruby-stdlib < 9.1.16.0 9.1.16.0

Details

As written in the advisory (Markdown source, shown as plain text).

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversal vulnerability in `install_location` function of `package.rb` that can result in path traversal when writing to a symlinked basedir outside of the root. This vulnerability appears to have been fixed in 2.7.6.

References

External links from the advisory. They lead to third-party sites.