GHSA-h8q5-g2cj-qr5h
Apache Tika is vulnerable to entity expansions which can lead to a denial of service attack
Packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| Maven | org.apache.tika:tika-core | >= 0.1, < 1.19.1 | 1.19.1 |
Details
As written in the advisory (Markdown source, shown as plain text).
In Apache Tika 1.19 (CVE-2018-11761), we added an entity expansion limit for XML parsing. However, Tika reuses SAXParsers and calls reset() after each parse, which, for Xerces2 parsers, as per the documentation, removes the user-specified SecurityManager and thus removes entity expansion limits after the first parse. Apache Tika versions from 0.1 to 1.19 are therefore still vulnerable to entity expansions which can lead to a denial of service attack. Users should upgrade to 1.19.1 or later.
References
External links from the advisory. They lead to third-party sites.
- https://nvd.nist.gov/vuln/detail/CVE-2018-11796
- https://access.redhat.com/errata/RHSA-2019:3892
- https://github.com/advisories/GHSA-h8q5-g2cj-qr5h
- https://github.com/apache/tika
- https://lists.apache.org/thread.html/88de8350cda9b184888ec294c813c5bd8a2081de8fd3666f8904bc05@%3Cdev.tika.apache.org%3E
- https://security.netapp.com/advisory/ntap-20190903-0002
- http://www.securityfocus.com/bid/105585