~ / search / GHSA-j44m-qm6p-hp7m

GHSA-j44m-qm6p-hp7m

Arbitrary File Overwrite in tar

Source: GitHub Advisory Database (reviewed) High CVE-2018-20834

Packages

EcosystemPackageAffectedFixed in
npm tar >= 3.0.0, < 4.4.2 4.4.2
npm tar < 2.2.2 2.2.2

Details

As written in the advisory (Markdown source, shown as plain text).

Versions of `tar` prior to 4.4.2 for 4.x and 2.2.2 for 2.x are vulnerable to Arbitrary File Overwrite. Extracting tarballs containing a hardlink to a file that already exists in the system, and a file that matches the hardlink will overwrite the system's file with the contents of the extracted file. ## Recommendation For tar 4.x, upgrade to version 4.4.2 or later. For tar 2.x, upgrade to version 2.2.2 or later.

References

External links from the advisory. They lead to third-party sites.