~ / search / GHSA-mh37-8c3g-3fgc

GHSA-mh37-8c3g-3fgc

RubyGems Escape sequence injection vulnerability in gem owner

Source: GitHub Advisory Database (reviewed) High CVE-2019-8322

Packages

EcosystemPackageAffectedFixed in
RubyGems rubygems-update >= 2.6.0, < 2.7.9 2.7.9
RubyGems rubygems-update >= 3.0.0, < 3.0.2 3.0.2

Details

As written in the advisory (Markdown source, shown as plain text).

An issue was discovered in RubyGems 2.6 and later through 3.0.2. The gem owner command outputs the contents of the API response directly to stdout. Therefore, if the response is crafted, escape sequence injection may occur.

References

External links from the advisory. They lead to third-party sites.