~ / search / GHSA-vjr2-wpfh-5r9p

GHSA-vjr2-wpfh-5r9p

Apache Ranger Hive Plugin missing permissions check

Source: GitHub Advisory Database (reviewed) High CVE-2021-40331

Packages

EcosystemPackageAffectedFixed in
Maven org.apache.ranger:ranger-hive-plugin >= 2.0.0, < 2.4.0 2.4.0

Details

As written in the advisory (Markdown source, shown as plain text).

An Incorrect Permission Assignment for Critical Resource vulnerability was found in the Apache Ranger Hive Plugin. Any user with SELECT privilege on a database can alter the ownership of the table in Hive when Apache Ranger Hive Plugin is enabled This issue affects Apache Ranger Hive Plugin: from 2.0.0 through 2.3.0. Users are recommended to upgrade to version 2.4.0 or later.

References

External links from the advisory. They lead to third-party sites.